Windows Update is broken for some Windows 7 users

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.


Malware Removal Specialist - Administrator
Jul 16, 2014
Some Windows 7 and Windows Server 2008 users are reporting they can't check for updates using Windows Update and Microsoft Update.
No word yet on a Microsoft fix

Windows 7 users are reporting problems checking for updates through Windows Update and Microsoft Update.

The root of the problem may be an expiration date that Microsoft needs to fix on its side, noted Computerworld earlier today.

A Microsoft Answers thread for those hit by the Windows Update Error 80248015 -- which began at some point on December 3 -- is growing.
I've also seen some with Windows Server 2008 reporting this same problem on Twitter.

I am one of those affected on my desktop Dell PC that's running Windows 7 SP1.
The message I am seeing is "Windows could not search for new updates."
When I click on the error code, I don't get any further information.
Others say they're receiving the message "Windows Update cannot currently check for updates because the service is not running.
You may need to restart your computer.

Some are suggesting that users apply an old fix and/or to change the system's date to something older than March 12, 2017.

I've got a question into Microsoft about when and how the company expects to fix this issue.
So far, no word back.

Windows 7 is slated to continue to receive security updates from Microsoft through mid-January 2020.

Likes: Tony D


Active Member
Aug 12, 2014
Dorset, England, UK
Windows 7
Windows 7
Firefox 57.0
Firefox 57.0
Hi Pete,

I had this problem in early December too. After trying System Restore without success, I searched on-line and found a possible solution which worked for me. It was as follows:
1) Stopping the Windows Update Service.
2) Deleting or renaming the Windows Update temporary storage folder ('Software Distribution' in the Windows folder).
3) Restarting the Windows Update Service.
This worked for me and Windows Update has worked correctly since. I believe Microsoft did have an Update server problem which they have addressed but it seems my 'Software Distribution' folder had been corrupted by the original problem.
Last edited: